ФЭНДОМ


Баджи, баджики, баджеты (очевидно, от слова "budget"), значки, лого - в общем, то, что, кроме цвета, отличает ваш корабль от вражеского.

Общие характеристики Править

Баджик должен быть размером 64x64 пикселя, в формате TGA, без компрессии.

Создание с помощью IrfanView Править

IrfanView - продвинутый просмотрщик изображений.

Чтобы создать баджик:

  • Откройте нужную вам картинку с помощью IrfanView;
  • Зайдите в Image->Resize/Resample (или просто нажмите Ctrl+R);
  • В блоке Set new size поменяйте Width и Height на нужные, а также снимите галочку с опции Preserve aspect ratio (proportional);

Если открытая картинка изначально не была квадратной, то у неё будут искажения. Единственный способ избавиться от этого в IrfanView - самостоятельно вырезать квадрат из исходной картинки.

  • Выделите рамочкой нужный вам кусок картинки; во время процесса, пока вы не отпустили ЛКМ, в заголовке окна будут показываться координаты курсора и ширина и длина выделяемого прямоугольника; следите, чтобы это был квадрат;
  • Затем нажмите Ctrl+Y или Edit->Crop Selection, чтобы обрезать изображение; (кстати, это меню стоит изучения - открываются довольно широкие возможности для редактирования изображений)

После этого просто уменьшите изображение.

Создание с помощью GIMP Править

GIMP - бесплатный многофункциональный растровый редактор, являющийся аналогом Photoshop.

Чтобы создать баджик:

  • Откройте картинку;
  • Зайдите в Изображение->Размер Изображения;
  • Измените ширину и высоту, перед этим откликнув пиктограмму цепи, чтобы не сохранялись пропорции картинки;
  • Нажмите "Изменить";

Если нужно сделать квадрат перед уменьшением, то можно воспользовать либо инструментом кадрирования:

  • Выберите инструмент кадрирования;
  • Выделите нужную вам область (размеры будут указаны внизу);
  • Нажмите Enter или просто сделайте ЛКМ по выделенной области;

Либо можно увеличить картинку:

  • Зайдите в Изображение->Размер Холста;
  • Измените ширину и высоту, перед этим откликнув пиктограмму цепи, чтобы не сохранялись изначальные пропорции;
  • Нажмите кнопку "Отцентрировать";
  • Нажмите "Изменить размер";

Прозрачность Править

Чтобы сделать прозрачными какие-то части картинки:

  • Добавьте в слой альфа-канал (ПКМ на слое - вероятно, название "Фон" - и выбрать "Добавить Альфа-канал");
  • Выделите ненужную часть;
  • Нажмите delete или Правка->Очистить;

Выделение Править

Для фигурного выделения вам чаще всего понадобятся инструменты

  • "Лассо";
  • "Выделение смежных областей" (с активным использованием клавиши Shift);
  • "Выделение по цвету";
  • "Контуры" (выделить всё, что нужно, затем нажать на кнопку "Выделение из контура");

Кроме того, весьма полезно сочетание клавиш Ctrl+I, позволяющее инвертировать выделение.

Раскраска Править

Чтобы залить какую-то выделенную область одним цветом, используйте

  • инструмент "Плоская заливка" с "Областью Применения" "Всё выделение" (иначе зальёт только похожие цвета);
  • Правка->Залить Цветом или Ctrl+,/Ctrl+. (залить основным/фоновым цветом), что более удобно, когда требуется закрасить очень много разнокалиберных выделений.

Ссылки Править